Model #79036603600 Kenmore Elite slide-in range, gas

  • Backguard
    3 Results
  • Burner
    3 Results
  • Body
    3 Results
  • Top/drawer
    3 Results
  • Door
    3 Results
  • Wiring Diagram
    3 Results

Question and Answers

Q:

Kenmore oven model 79036603600 not heating properly.

A:

Since the broiler works, that oven temperature sensor probe is probably okay. You could have a weak or failed bake burner igniter that is causing this problem. The theory of operation for that ignition system in your oven is shown in the image below. Here is a video that illustrates that process. Check to see if that igniter is glowing in the bake mode. If it is, then you will probably need to replace that igniter. The bake and broiler burners appear to use the same type of igniter in this range. You can try switching those igniters (with the range unplugged or the house circuit breaker for the range shut off ). If the oven heats properly in the bake mode after switching those igniters then this verifies that you have an igniter failure. Replacing the bad igniter in that situation should fix your problem.

You can order that igniter from this page: Igniter for Kenmore Range 790.36603600 . Be sure that you unplug the range or shut off the house circuit breaker to disconnect electrical power before accessing and replacing that component.

If the igniter is not glowing in the bake mode, then you could still have a bad igniter. You could also have a wiring failure in that ignition circuit or a failed electronic clock control board.

If you need more help, reply with additional details and we will assist you further.

If you get to the point where you need to have a service technician diagnose and repair this failure, you can schedule service through this link: Sears Home Services .

Read More
Lyle W -
Sears Technician
July 05, 2012