Model #F5865-900 HOOVER Power Steamer

  • Housing/handle
    3 Results
  • Hood/base
    3 Results
Find part by diagram >

Question and Answers

Q:

Replacement part for HOOVER Steam Vac does not work

A:

I know it can be very frustrating to have an appliance you depend on break down. Managemylife.com is always a great resource to find the answers to just about anything. I would suggest that you provide the model # and any other information that you think may help your expert respond with the best possible response. Continue this existing thread, just click on reply below and then add your information. This will speed up the process. I did do some research for you at Managemylife and found an expert answer to a similar question. This may shed some light on the problem until your expert can respond. The link has been attached below.

Read More
James -
April 26, 2011
A:

Thank you for your question.

I can understand you questioning why the replacement part is not working for your machine.

If you could send the model number for the Hoover Steam vac, it usually starts with an F and I will contact the manufacture to see if you in fact you have the correct control rod and what you will need to do.

I did a backwards look up using the part numbers and found model that uses the same part numbers as yours.

F5885-900

Is it possible that you received a lower rod instead of an upper rod?

If that is the case I would return that part and re-order.

If you need more help please reply with your model number and I will be happy to help you further.

Thank you for using Manage My Life.

Read More
Sam A -
Sears Technician
April 27, 2011
A:

The MODEL # is F5865-900, SERIES N7.9, the part is 95% the same as the original, exception is the lower end which connects to the lower control rod. It is lacking a slot/groove in the end allowing it to attach/snap it to the other control rod.

Read More
nataleg -
April 27, 2011
A:

No, did not get the lower rod, I double checked the diagram on the parts site and lower rod has a different shape and size. Either the part I received is a factory defect or is the wrong part number on the site to fit my model. Sears customer service is clueless on all of this.

Read More
nataleg -
April 27, 2011
A:

Thank you for the update. I have confirmed with the manufacture that you do have the correct part numbers for the upper and lower rods. I cannot speak to if it is defective or if you just received the wrong part. I will give you a link to the Hoover site for these parts. If you do not trust the Sears web-site you could try the Hoover site for parts. I hope you get this resolved, and I am sorry that we did not serve you better, because it is our goal to service every customer with the correct information a be you trusted advisor. Thank you. Sam A.

Read More
Sam A -
Sears Technician
April 27, 2011
A:

Thank you , I will take that link to see what I can find.

Read More
nataleg -
April 27, 2011
See more answers