Model #917270812 CRAFTSMAN Lawn, Tractor

Find part by diagram >

Question and Answers

Q:

Tranmission Pulley belt off 917270812 Craftsman 19.5 hp electric start 42

Q:

30 amp fuse blows 917.270812

A:

Thanks for the inquiry and for being a valued member.

I am sorry to hear of the issue you’re having with the tractor. I know how frustrating that is.

If you turn the key to the run position and a 30amp fuse is blowing you more than likely have a short to ground. Somewhere in your wiring you are going directly to ground. I would begin checking everything carefully right from the battery on back till you find the problem. Check anywhere wires runs beside, under, or on top of any sharp metal piece for a bare spot, then if you find one, tape it up. Also, check the place where the battery negative or black cable goes to ground to see if the connection is rusty or loose. Check where the wires come out from under the flywheel cover, there might be a bare wire there. Where the headlight wires plug together near the hood hinges and make sure the battery connections are tight.

A shorted diode or a shorted alternator could cause the fuse to blow. Check around the wires going into the alternator to see if there is heat shrink that would contain a diode. If so, you could go to an automotive store and replace it. If there isn’t a diode nearby, it may be an issue with the alternator if you do not have a short to ground.

I hope this helps and thanks for using SearsPartsDirect.com. We appreciate your business.  

Read More
Jeff Wallace Sr -
Sears Technician
June 29, 2015
Q:

Attachment clutch lever won't engage lawn mower blades. Very difficult to move the lever. Wont go full distance of slot. Craftsman 42 inch lawn tractor. 917.270812

A:

Thanks for the inquiry and for being a valued member.

I am sorry to hear of the difficulty you're having with the blade clutch lever on the tractor. I know how frustrating that is.

It sounds like something is either binding on the idler arm on the deck, or the pivot for the idler needs to be lubricated. It sounds like the cable is connected, but is just having difficulty putting tension on the belt because of a stiff idler arm bracket. You will need to clean the bracket the blade cable connects to and oil it if needed. That should solve the issue.

I hope this helps and thanks for using SearsPartsDirect.com. We appreciate your business. 

Read More
Jeff Wallace Sr -
Sears Technician
April 21, 2015

Top Parts