Model #79078409010 KENMORE ELITE Free Standing, Gas

  • Backguard
    3 Results
  • Burner
    3 Results
  • Body
    3 Results
  • Top/drawer
    3 Results
  • Door
    3 Results
Find part by diagram >

Question and Answers

Q:

Manual for Kenmore Elite Gas Range does not have delineated sequence to set convection oven for 200 degrees.

A:

I am sorry that you are having some difficulties with your range and I will be happy to help. I suggest you add to the thread of this question and include the full model number of your range so that the expert can provide you with a more detailed answer. I did manage to find a link with a similar question. I hope this helps with the range troubles, while you wait for your expert response.

Read More
Joseph P. -
July 14, 2012
A:

Thanks, Joseph P! It seems it's the range and not me. Wish the manual was written more in a 'cheat sheet' format, making it easier to use.

Read More
Anonymous -
July 14, 2012
A:

I know that it can be very difficult to have issues with your oven. However, without your model number, I am unable to find any information on this issue. It sound like you may have a problem with the meat probe or the electronic oven control. It is also possible that the probe may not be connected all the way. If you could please reply with this information, I can provide a more detailed answer. Thank you for using Manage My Life.

Read More
AnneJ -
Sears Technician
July 17, 2012
A:

My range's model number is 790.78409010, manufactured in 2008. Hope that helps. If you need any more information, let me know. Thanks in advance for your help!

Read More
Frank -
July 17, 2012
A:

Thank you for your model number. It looks like you may be missing a step when using the meat probe. On this model the first temperature setting is what you want the internal temperature on the roast to be. If you put in 200 degrees then the oven will roast it until it reaches 200 degrees inside the roast. The next temperature setting is for the oven. This is the one that cook the meat. If the oven is still not heating then it is most likely the meat probe is faulty, and needs to be replaced. Please let me know if you need anything else. Thank you for using Manage My Life.

Read More
AnneJ -
Sears Technician
July 18, 2012
See more answers

Top Parts