Model #79046629504 KENMORE ELITE Slide-In Range, Electric/Gas

  • Backguard
    3 Results
  • Burner
    3 Results
  • Body
    3 Results
  • Top/drawer
    3 Results
  • Door
    3 Results
  • Wiring Diagram
    3 Results
Find part by diagram >

Question and Answers

Q:

Oven has failed to work after running Flex-Clean

A:

I know how important it is to have a good working range in the home so that you can create a great meal. While you are waiting for an expert answer, I did manage to find a link that describes a similar problem to the one that you are having. I hope my link is useful.

Read More
Joseph P. -
January 13, 2011
A:

This link was quite helpful! The element read out at 14 ohms and the voltage was only about 54 volts A/C. I suspect that the control board failed during the cleaning cycle. This seems like a failure that should not have occurred! The range is only 4 years old and the oven is not used that often!

Read More
George -
January 13, 2011
A:

A number of things could cause the oven to not work after a clean cycle. The broil element you tested is good. Be sure the circuit breaker is not tripped.

If you are getting 54 volts to the broil element, the circuit breaker might be tripped or a wire might have burned. I would disconnect the power to the range and remove the rear panel. Check the wiring connections for a discolored terminal.

If you don't find any problems, I recommend you go to http://services.sears.com/shs/category/repair?sid=MMLxexpertxmerch and get a Sears technician to repair the range.

Read More
Jimmy K -
Sears Technician
January 14, 2011
See more answers
Q:

Kenmore dual fuel range.

A:

Please provide the model number & symptoms of your range & resubmit your question.

Read More
biker dave -
Sears Technician
A:

790.46629504 Dual Fuel range. Ran Flex-Clean for the first time yesterday and it worked great. Unfortunately, the electric oven no longer functions! Warming oven works. Pulled the heating element in the top (it only has one) of the oven and it read 14ohms. Can't understand what is going on. I have cycled the power off and on, with no change. /George

Read More
George -
January 13, 2011
See more answers

Top Parts