Model #66517502200 KENMORE Dishwasher

  • Door And Panel Parts
    3 Results
  • Control Panel Parts
    3 Results
  • Door And Latch Parts
    3 Results
  • Lower Washarm Parts
    3 Results
  • Heater Parts
    3 Results
  • Fill And Overfill Parts
    3 Results
  • Tub And Frame Parts
    3 Results
  • Pump And Motor Parts
    3 Results
  • Upper Rack And Track Parts
    3 Results
  • Upper Wash And Rinse Parts
    3 Results
  • Lower Rack Parts
    3 Results
  • Miscellaneous Parts Optional Parts (not Included)
    3 Results
Find part by diagram >

Troubleshooting

Error Codes

Error Code:

Condition:

Check/Repair:

Question and Answers

Q:

Kenmore dishwasher making a loud grinding noise and heating problem

A:

I can understand your frustration over your dishwasher making a loud grinding noise. I did some research and provided a link to a similar question and answer on our site. I hope this will shed a little more light on the issue until the Expert responds to your question in more detail within 24 to 48 hours.

Read More
Julio -
March 12, 2013
A:

I know that it can be very frustrating to have issues with your dishwasher. From what you are describing it sounds like both the heating element and the impeller need to be replaced in your dishwasher.  The impeller for this about $124.04 and the heating element is about $33.29.  If you think that your are pretty handy, you can try to replace these yourself. Please let me know if you would like the information on how to do this.  If not then I would suggest that you schedule service.  You can do so at this link: Sears Home Services.  As for the Whirlpool, I did some research and found that it seems to have a major problem with the drain pump.  I hope this helps.  If you need further assistance, please reply to this thread.  Thank you for using Manage My Life.

Read More
AnneJ -
Sears Technician
March 13, 2013
A:

Hi thanks for both of your help. I fixed the noise. I couln't figure hot how to gain access to the chopper. But found a youtube video that showed me there was a tab holding the chopper cover on and i finally got it off to find the chopper was destroyed. lol So I got all the broken pieces out and took the chopper from the other dishwasher and put it in and that fixed it. So the noise is gone. As for the heating part. I'm not real sure about. during drying I can feel heat coming from the port on the front of the dishwasher. But when I put in on pots and pans mode or hi temp scrub or sani rinse. It takes a long time but when it's done the clean or the sanitized led light flashes. I can't remember which one does it but one led stays on and one flashes. I believe from what I got from the manual means it didn't reach that temp. But not sure. It seems like it's getting hot but not hot enough. Thanks again for all your help.

Read More
DAVID -
March 13, 2013
A:

I don't have the dishwasher hardwired. I have it hooked up with a plug-in cord I bought from lowes. the guy at lowes told me which one to get. It was a thicker gauge but not sure if that makes a difference or not. maybe a 14 gauge but can't remember. thanks for your time and help. So should I get a new heating element or does the power cord need to be heavier duty then the one I got. It is a 3 prong. Thanks again.

Read More
DAVID -
March 15, 2013
A:

Thank you for replying David. I have happy to hear that you got the chopper working properly. As for the heaing, you will need to test the heating element with an ohm meter to make sure its working properly. You will need to remove the toe panel at the front of the dishwasher. The wires coming off the element should ohm out between 10-35 ohms. If it does, then you are looking at a problem with the thermostat. If it does not then the problem is the element. Please let me know if you need anything else. Thank you for using Manage My Life.

Read More
AnneJ -
Sears Technician
March 15, 2013
See more answers

Top Parts