Model #21637045800 KENMORE Vacuum, Upright

  • Housing Assy
    3 Results
  • Base Assy
    3 Results
  • Filter Assy
    3 Results
Find part by diagram >

Question and Answers

Q:

Replacing Vacuum Hose 21637045800 Kenmore Vacuum

A:

Thank you for your inquiry on your Kenmore Vacuum, Model: 216.37045800. From reviewing the details on your model, I have provided an image from the manual which advises you on how to remove the hose.  

 

Safety Warning: Before beginning the repair, disconnect the direct power supply to the vacuum to prevent the risk of injury or any electrical shock.

If you don’t feel comfortable or confident in this repair, then you can have it repaired at home by a sears technician. I have the included a link to the website: Sears Home Services or call 1-800-469-4663.

 

I hope this answered your question. Thank you for contacting SearsPartsDirect.com, and have yourself a wonderful day. 

Read More
Gerry 93 -
Sears Technician
May 23, 2015
A:

That small hose is not the one I was referring to. The hose I was referring to is the one used in daily use that can detach and be used with the attachment tools. The part we ordered came with a Y shaped attachment piece with the replacement hose already attached. My question was how to remove the front piece covering the existing Y shaped piece with out damage. Also, your attachment image was very, very small and barely viewable. Thanks again for your help.

Read More
Meg -
May 23, 2015
See more answers
Q:

my Vacuum belt keeps breaking minutes after I replace it.

A:

The belts breaking on the vacuum can get to be very frustrating. I did some research on www.managemylife.com and found a similar question to yours. I am adding the links below to help you with your question while you wait for your expert response. The first link is for the problem, and the second is for the owners manual. The belt information is on page 13. I hope this helps.

Read More
Marc H -
February 28, 2012
A:

Thank you for your question on the breaking of the replacement belts for the upright vacuum cleaner.

I will give you the instructions from the owner's manual just in case you do not happen to have them.

Please observe the location of the belt tighten pulley.

If you have done the belt replacement correctly then I would suggest making sure the roller brush bearings spin freely.

If the belt is being burnt at the motor pulley shaft it will point to the roller brush bearings as the most likely problem.

I am going to assume that you are using the correct belt as listed in the link below.

Please let me know how it went and if this did not solve the problem we can continue troubleshooting with the new information..

Belt for vacuum .

Sam A.

Read More
Sam A -
Sears Technician
February 29, 2012
A:

In response the model number for my vacuum is 216.37020700 and the serial number is 3807024256. The replacement belt I am buying is Part # 1-860140-600, Style # UB-11. I have the owners manual. I have checked the roller brush and it is spinning freely. The belt has no odor of burning, it just snaps in half after less than an hours use.

Read More
Norman Graham -
March 19, 2012
A:

Thank you for the update Norman. If you are sure that the agitator is rolling freely and the idler pulley is operating the belt correctly as per the picture in the manual, then I think you may have encountered a bad batch of belts if they snap clean as you say. Maybe you will need to get some belts from a different source so you are using belts from a different batch. I will give you a link below for some of these belts. The other option is to purchase some of these belts from a different retail store. If you do that and they work better please let me know so I can inform our parts vendor of the problem. Sam A.

Read More
Sam A -
Sears Technician
March 20, 2012
A:

In response the model number for my vacuum is 21637045800 IT WON'T PLOW THROUGH THE HOLE ALL THE HOLE IS CLEAN WHAT MATTER WITH THIS ?????

Read More
Anonymous -
April 18, 2012
A:

Thank you for your question on the vacuum cleaner. Are you having belt drive problems with your vacuum cleaner? Please give me a little more detail as to the problem you are having. Sam A.

Read More
Sam A -
Sears Technician
April 19, 2012
A:

I had the same problem. The new belt broke within 30 minutes of replacement. It is an easy replacement and the brush roller was spinning freely but I ended up breaking four new belts. This vacuum was made for Sears by Dirt Devil so I went to an independant parts dealer that sold Dirt Devil belts and that solved the problem. The Dirt Devil part # for their belt is the same part # as Sears. The Dirt Devil belt is wider, longer, thinner and more pliable than the Sears belt. Sears has gotten some defective belts from their supplier. You get two Dirt Devil belts for $6.00 whereas at Sears you get one belt for $5.00. My question for Sears is how about a $20.00 refund for the four defective belts I bought from them?

Read More
Norman Graham -
April 19, 2012
A:

Thank you for the update on the belts for the vacuum cleaner. This validates my suspicion on the bad belts. I have made the buyer aware of this issue and I will forward your request to management to see what can be done to honor your request. We value you as a customer and want you to be happy with the products we sell and service. Thank you for using Manage My Life. Sam A.

Read More
Sam A -
Sears Technician
April 20, 2012
A:

Mr. Norman Graham could you please send your contact information to my e-mail address? I have contacted management and we will need your contact information so our Blue Ribbon group can contact you about your request. Please send it to: sande38@searshc.com. Sam A,

Read More
Sam A -
Sears Technician
April 20, 2012
A:

THANK YOU for giving me ideas on my vacuumn..Everyone else says "I have been doing something wrong"..it's not hard to follow instructions. Anyway, I bought an upright Dirt Devil vacuumn, new from walmart on 12-01-08. I have literally used it about 4 times (vacuuming normally) up until 2012. 4 times in about 4 years. That was the last year they made that vacuumn. My model number is 087305. I have bought the right belts, put in the right belts, followed the simple instructions to the tee. I have the same issue..I turn it on and within a second I smell burning and it's snapped in half. i have gone thru 4 belts and gave up. However, since I bought it and it was not used hardly at all, and I feel like the vacuum cleaner would run good if this problem is happening..I would like to keep it..it's just like new. You mentioned to someone else that this would point to the roller brush bearings...What can i do to fix this? is it fixable? Thank you very much!

Read More
Thien -
April 30, 2012
See more answers

Top Parts